ICode9

精准搜索请尝试: 精确搜索
  • 在android studio中更改gradle构建目录?2019-09-30 10:36:14

    我刚刚bet356体育下载_bet356客服邮箱_bet356官网了Android Studio,而我正在学习使用Gradle构建.但是,使用默认项目设置,我的构建位于项目目录中,我希望将它们放在其他位置(最好在项目目录之外).是否有可能实现这一目标?我在哪里进行更改以及我要做出哪些更改?解决方法:在root build.gradle中 allprojects { buildDir

  • 任务’:app:compileDebugJavaWithJavac’Android Studio 3.1 Update的执行失败2019-09-30 08:34:25

    我在更新Android Studio 3.1 Canary 6的版本后收到错误 在它成功运行之前,我不知道它为什么会发生. org.gradle.api.internal.tasks.compile.CompilationFailedException: Compilation failed; see the compiler error output for details. at org.gradle.api.internal.tasks.

  • java – Gradle中的“提供”依赖项2019-09-30 07:00:51

    我在我面前有build.gradle,并且有一些依赖项被声明为提供但在documentation中我没有看到这个依赖范围. dependencies { compile("org.springframework.boot:spring-boot-starter-web:1.2.4.RELEASE") .... provided 'backport-util-concurrent:backport-util-concurr

  • java – 如何通过在gradle命令行上传递version属性来设置project.version?2019-09-30 05:00:56

    我想用命令行传递的自定义版本构建JAR,例如: 当我像这样执行gradle构建任务时: gradle build -Pversion=1.0 应该生成myproject-1.0.jar. 我尝试将下面的行添加到build.gradle中,但它不起作用: version = project.hasProperty('version') ? project['version'] : '10.0.0' 解决方

  • 更新到Android Studio 3.0后无法运行Ionic应用程序2019-09-30 03:37:31

    这是我的离子信息 cli packages: (/Users/billb/dev/customer-mkt-app/node_modules) @ionic/cli-utils : 1.15.2 ionic (Ionic CLI) : 3.15.2 全球套餐: cordova (Cordova CLI) : 7.0.1 本地包裹: @ionic/app-scripts : 3.0.1 Cordova Platforms : android 6.2.3 ios 4.4.0

  • 未解决的依赖项:找不到与com.android.support:appcompat-v7:29匹配的任何版本.2019-09-29 17:24:26

    参见英文答案 > Android Studio keeps refusing to resolve com.android.support:appcompat-v7:29.0.1????????????????????????????????????4个 当我在intelliJ上打开一个新的android项目时,总会出现这个未解决的依赖错误 我努力了: >取消选中

  • 将-P参数从android studio传递给gradle2019-09-28 20:26:08

    android studio里面有一个功能可以做这样的事情. 基本上我的gradle脚本读取名为version的参数,根据该参数设置某个库的依赖版本.因此,当我执行gradlew -Pversion =’1.2.3’时,我在gradle中得到了这个字符串.但这只有在我从控制台调用gradle时才有效. 有没有办法在Android Studio中

  • 使用gradle,“ – 文件名或扩展名太长错误”2019-09-28 18:13:34

    我最近更新了我的代码,当我尝试在命令行中使用g bootRun运行我们的应用程序时,我遇到了这个错误. 堆栈跟踪: org.gradle.api.tasks.TaskExecutionException: Execution failed for task ':bootRun'. at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecute

  • android – 为每个Build Variant使用不同的manifestPlaceholder2019-09-28 17:27:58

    我首先要说的是我对Gradle很新,所以如果已经回答,我会道歉. 我正在开发一个使用API??密钥访问第三方工具的Android应用程序.根据应用程序的风格和构建类型,需要使用不同的API密钥. 这是我正在尝试做的基本概述: android { defaultConfig { manifestPlaceholders = [

  • 无法找到属性android:font for v7 support2019-09-28 14:26:30

    我一直在开发一款Linphone应用程序,但却陷入了困境.我已经更改了应用名称并重构了所有相关包.应用程序没问题,直到我将gradle升级到3.0.0. AGPBI: {"kind":"error","text":"error: resource android:attr/fontStyle not found.","sources":[{"file":"~/.gradle/

  • Android Studio使用具有相同包名的库和项目2019-09-28 13:26:47

    我有一个库,我用作所有Android应用程序的基础,并有以下清单文件:

    spring – 如何将系统属性传递给Gradle任务2019-09-28 11:19:26

    我正在使用Gradle spring-boot插件,我需要为测试运行选择一个弹簧活动配置文件. 如何将spring.profiles.active系统属性传递给bootRun插件的任务? 什么已经失败: task bootRunLocal { systemProperty "spring.profiles.active", "local" System.setProperty("spring.profile

  • java – 如何读取属性文件并使用项目Gradle脚本中的值?2019-09-28 11:00:53

    我正在处理Gradle脚本,我需要读取local.properties文件并使用build.gradle中属性文件中的值.我是以下面的方式做的.我运行下面的脚本,它现在抛出一个错误,但它也没有做任何事情,如创建,删除和复制文件.我试图打印变量的值,它显示正确的值. 如果这是正确的方法,有人可以告诉我吗?我认

  • 运行react-native run-android时出错2019-09-28 09:24:46

    A problem occurred configuring project ':app'. > Could not resolve all dependencies for configuration ':app:_debugApk'. > A problem occurred configuring project ':react-native-fbsdk'. > Could not resol

  • Android Studio无法解析导入的AAR模块中的符号2019-09-27 22:25:11

    类似问题中的所有答案都谈论了manderally编辑gradle文件.但我已经使用Android Studio导入AAR文件并检查了build.gradle文件,它们看起来都是正确的. 我的问题是: 我已经导入了ShowCaseView v5.0.0 AAR但是当我尝试在我的Tutorial.java文件中导入类时(你可以看到红色),Android Studio

  • java – 加速Android构建过程2019-09-27 20:03:57

    这是一个真正的noob问题.我为一家公司工作,该公司生产100个使用大部分相同组件的应用程序.在构建时有一些小的定制,我们希望加快速度,以提高效率.大多数自定义是在运行时从服务器下载数据完成的. 我们能够以最快的速度获得完成.apk的项目大约需要15分钟.此过程涉及更改包名称,图标

  • java – Manifest合并失败:属性应用程序@ appComponentFactory更新Firebase库2019-09-27 20:00:43

    我正在尝试在我的项目中添加firebase,但是当我实现’com.google.firebase:firebase-messaging:19.0.0’和’com.google.firebase:firebase-core:17.0.0’时. build.gradle(这是错误) apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' androi

  • java – API’variable.getMergeResources()’已过时,已替换为’variant.getMergeResourcesProvider()’2019-09-27 19:04:33

    我在项目中遇到了非常恼人的警告: WARNING: API 'variant.getMergeResources()' is obsolete and has been replaced with 'variant.getMergeResourcesProvider()'. It will be removed at the end of 2019. For more information, see https://d.android.com/r/tools/t

  • android – 如何降级到旧版Gradle2019-09-27 10:25:51

    我的.gradle文件夹中有一个2.4文件夹,它是gradle的版本. 我想降级到2.2.1,因为我需要使用Gradle插件1.0.1.我已经尝试改变: distributionUrl=https://services.gradle.org/distributions/gradle-2.2.1-all.zip 但这并没有解决,我仍然使用2.4版本. 我怎么解决这个问题?解决方法:在

  • android – Gradle错误:配置声明未声明的依赖项2019-09-27 01:24:47

    我正在制作我的第一个Android服装应用程序,但我无法让Android Studio工作. 首先我得到了错误 "Project with path ':wear' could not be found in project ':mobile'. 通过在settings.gradle中添加“include”:wear“解决了这个问题.但随后出现了一个新错误: "Error:Module vers

  • java – Android Studio 3.0 DexArchiveBuilderException2019-09-27 01:00:00

    编译仪器测试时我遇到了这个错误. Error:com.android.builder.dexing.DexArchiveBuilderException: Failed to process /Users/rafaelruizmunoz/SourceTree/Weather/app/build/intermediates/transforms/desugar/androidTest/debug/1.jar Error:com.android.builder.dexing.DexAr

  • android studio java.lang.NoClassDefFoundError Gson2019-09-27 00:02:54

    我做了一个很新的项目.我通过谷歌将gson库添加到我的projects / libs目录并将其添加为库.我还将它添加到我的build.gradle中 compile files('libs/gson-2.2.4.jar') 所以现在一切看起来都不错,Android Studio没有任何错误,任何地方都没有红色下划线.我可以建立它并试一试. 但后来

  • AndroidStudio使用阿里云仓库提高加载依赖速度2019-09-26 21:42:28

    大概 我们在使用一些第三方框架时,需要在项目中添加相应的依赖,默认添加依赖时从jcenter()这个仓库下载东西的速度非常慢,只要我们改用阿里云的仓库就可以大大提高加载速度。 操作 只需要在项目的build.gradle(不是app目录下的那个build.gradle,是外面那个)中加入下面的代码

  • android – 更新到3.0后Gradle构建失败2019-09-26 19:25:46

    我最近将我的项目的gradle版本从2.14.1更新到3.0.从那时起,每次出现此错误时,gradle构建都会失败: Error:Cause: org.gradle.api.internal.tasks.DefaultTaskInputs$TaskInputUnionFileCollection cannot be cast to org.gradle.api.internal.file.collections.DefaultConfigurabl

  • ConfigurationProperties与 lombok的注解 编译时 栈溢出2019-09-26 19:06:49

    在执行 ./gradlew assemble时 ,出现了java.lang.StackOverflowError的异常。启用 --stacktrace参数,发现异常栈中的方法循环调用位于这个类中org.springframework.boot.configurationprocessor.ConfigurationMetadataAnnotationProcessor。该类用于处理ConfigurationProperti

专注分享技术,共同学习,共同进步。侵权联系[admin#icode9.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有