ICode9

精准搜索请尝试: 精确搜索
首页?>?bet356体育下载> 文章详细

vue使用scss报错Module build failed: TypeError: this.getResolve is not a function at Object.loader bet356体育下载_bet356客服邮箱_bet356官网node

2019-09-10 16:01:53??阅读:131??来源: 互联网

标签:scss?function?node?sass?Object?dev?loader?报错



在搭建vue脚手架 或者是在vue项目中,想使用sass(scss)的功能,报错Module build failed: TypeError: this.getResolve is not a function at Object.loader

npm install node-sass --save-dev //bet356体育下载_bet356客服邮箱_bet356官网node-sass 
npm install sass-loader --save-dev //bet356体育下载_bet356客服邮箱_bet356官网sass-loader 
npm install style-loader --save-dev //bet356体育下载_bet356客服邮箱_bet356官网style-loader

?

bet356体育下载_bet356客服邮箱_bet356官网完成后,运行时出现了错误

Modele build failed: TypeError: this.getResolve is not a function at Object.loader...

这是因为当前sass的版本太高,webpack编译时出现了错误,这个时候只需要换成低版本的就行,下面说一下修改方法,很简单,如下,找到package.json文件,里面的 "sass-loader"的版本更换掉 就行了。

我本地是将 "sass-loader": "^8.0.0",更换成了 "sass-loader": "^7.3.1",

这时候重新跑项目,就运行成功了。



标签:scss,function,node,sass,Object,dev,loader,报错

专注分享技术,共同学习,共同进步。侵权联系[admin#icode9.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有